Gun Hub Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
Hello,

I have recently gotton a chinese norinco sks m , and am in the process of reasssembly after taking out the bolt carrier group...

My problem is this: When im putting the bolt group back into the receiver, it wont go all the way forward, unless i push down on a protruding peice of metal that blocks the bolt , it seems to be part of the trigger group as far as i can tell...

If i push it down and then slide the assembly in on top of it, then it all will go together... But, that little sharp peice of metal is riding up against the bottom of the bolt under spring pressure?

My question is this: Is that normal??? Because its not mentioned in the sks reassembly, that i am reading too put this back together, and I dont want to damage the rifle if it has somthing wrong with it .
 

·
Registered
Joined
·
568 Posts
Normal...I'm not sure what that little piece is called (disconnector maybe?) but you do have to push down slightly to overcome the spring pressure when re-installing the bolt. If it all goes together and goes into battery properly you should be OK.
 

·
Registered
Joined
·
63 Posts
Discussion Starter · #3 ·
Normal...I'm not sure what that little piece is called (disconnector maybe?) but you do have to push down slightly to overcome the spring pressure when re-installing the bolt. If it all goes together and goes into battery properly you should be OK.
Yep, Its the disconnector... mine seems to rub the bottom of the bolt and its a sharp little bastard too!!! I just hope it doesnt rub a big gouge in the bolt bottom...its already leaving a mark where it rubs... I wonder what it would take to polish it up reeeaaalll shiny ???
 

·
Registered
Joined
·
134 Posts
It needs to contact the bolt. If you remove too much metal, you won't be able to get the trigger to engage. Leave it alone,it will polish itself.
 

·
Registered
Joined
·
1 Posts
I was wondering if anyone ever had issues with spring pressure with an SKS, I took it to the range everything was fine then after I cleaned it suddenly the bolt is much more difficult to open the usual and slams the shut much harder than before. Everything else seems fine about the gun but I'm worries something happened to the spring or my reassembly
 
1 - 5 of 5 Posts
Top